App intall failed

So this is my first purchase on this store... it was kind of hard but that's another topic. right now all i want is to download my app.. so i added funds to my wallet and made the purchase from my computer, i was hoping after all that i would just download the app.. but no i had to go to the slide me store on my phone... so i did exactly that, went to my locker and tried to download my app AGAIN! and there's this notification that goes like this "you will not be billed for this transaction. Application install failed, was canceled or already installed." OK so... i did not cancelled the download nor have it already installed. My phone is Xperia Play and i also have the latest version of slide me app... i feel scammed can somebody help me out?

Download from StorageLocker

If your app failed to download it could be due to file delivery issues at the time. You can try to re-download your purchased applications from your StorageLocker account, providing you have a 'Completed' transaction and application is maintained as published by its publisher/developer.
StorageLocker is accessible from the SlideME Market (SAM) app. SAM > Menu > More > StorageLocker

Apologize for the problem that you may have experienced in receiving the file download.


Is teamviewer available from Slideme?

Live Wallpaper force closes

I purchased this Live Wallpaper and every time I try to apply it it seems to force close. I've tried other LW and they apply with out a problem. What could be the problem and is there a way to fix this issue?

Installing Apps

I am trying to install apps on my tablet And it keeps saying installing failed in the notification. Why can't I install any apps and how do I fix this problem?

Cannot download any app.

I am also getting the same error.
"You will not be billed for the transaction, application install failed, was cancelled or was already installed."

I didnot purchase anything, so it is not available in the StorageLocker. How can I download the free softwares, for those also I am getting this error.