Speed Forge 3D at 1 fps on Archos 5 tablet

Just a friendly heads-up but the game only runs at 0.5 - 1 frame per second on Archos' 5 inch tablet.
At the same time the target for the menu controls (button touch areas, select box indicators) are somewhat above and to the left of the actual graphics.

The menu problems can be compensated for if you know the problem exists but the practically nonexistant motion makes the game unusable.

Might be a good idea to append your warning in the game's description.

Post it under developers Application Profile

May I suggest that the best place to post such info is under the actual developers application profile, > https://slideme.org/application/speed-forge-3d

This way they can notice the post and adapt or respond accordingly.


That's what I tried at first

That's what I tried at first but the note when editing a new reply there is pretty hard to misunderstand:

"Please do not post bug reports in reviews. Use forums or contact developer directly to get support."