Drone Ops: First Strike Drone Ops: First Strike v2.1.0

Download Drone Ops: First Strike

This Drone Simulator game lets you play as a militairy UAV (Unmanned Aerial Vehicle) operator. Do you have the skill to fly covert recon missions while taking out high profile targets? Your mobile device is your control center. Don’t drop your concentration…. Good luck pilot! This RC fighter bird is a highly efficient piece of kit. You will fly the drone strike fighter by using an intuitive wifi based control system. Both combat missions and reconnaissance missions are available and it your prime objective to take out enemy jets and navy. Attack ground-based targets, while you dodge incoming anti-air fire. Engage in epic air-2-air combat dogfights and become a true top gun pilot by waging war on a wide range of enemy aircraft. Avoid invaders, fly shadow missions, take out the flak cannons and unleash oblivion on the enemy.

Application

Parental rating: 
Teen (age 13 and over)
Default language: 
English
Supported languages: 
Afrikaans, Amharic, Arabic, Belarusian, Bulgarian, Catalan, Czech, Danish, German, Greek, English (United Kingdom), English (India), Spanish, Spanish (United States), Estonian (Estonia), Persian, Finnish, French, French (Canada), Hindi, Croatian, Hungarian, Armenian (Armenia), Indonesian (legacy in code), Italian, Hebrew (legacy iw locale), Japanese, Georgian (Georgia), Khmer (Cambodia), Korean, Lithuanian, Latvian, Malay (Malaysia), Norwegian Bokmål, Dutch, Polish, Portuguese, Portuguese (Brazil), Portuguese (Portugal), Romanian, Russian, Slovak, Slovenian, Serbian, Swedish, Swahili, Thai, Tagalog, Turkish, Ukrainian, Vietnamese, Chinese (China), Chinese (Hong Kong SAR China), Chinese (Taiwan), Zulu
Trial version: 
No
"In-App" billing: 
No
With advertisements: 
Yes
Screenshots: 
Drone Ops: First Strike
Drone Ops: First Strike
Drone Ops: First Strike
Drone Ops: First Strike
Drone Ops: First Strike

Requirements

Requires Google Play and/or account: 
No
Requires third-party libraries: 
No
Requires 'rooted' device: 
No
Target Android version: 
Android 4.4W
Minimum Android version: 
Android 2.3
Requires features: 
Screen landscape, Sensor accelerometer
Requires permissions: 
Access network state, Internet, Read phone state
Free

Discussions on Drone Ops: First Strike

There are no comments yet.
Syndicate content

Reviews of Drone Ops: First Strike

There are no reviews yet.
Syndicate content