My App Locker is Empty!

I have Hard Reset my Milestone and now I can't redownload my paid app. The Locker says it's empty.

Shouldn't I be able to re-download any already purchased app I've got from you, guys?

StorageLocker Issues

We checked your transactions and indeed they are set to 'Completed'. Once they are as 'Completed' they should appear in your StorageLocker account once you login.

Can you please try login again.

Can you confirm if you are using latest SAM 3.4 version?

We have received such reports with StorageLocker problems, but we can not seem to replicate the problem internally.

Would like to work with you on this issue and trace the login attempts, so we would appreciate if you could contact support when its a good time for you to attempt to login.

Alternatively, if your applications are not in StorageLocker, the alternative way to re-download your already purchased applications that appear as 'Completed', will be to try to go through the process and purchase again. Since that app is with a 'Completed' transaction status you will not be billed again.

Hope this helps.

Your suggestion doesn't work.

Just made my first app purchase three days ago...download failed. Still doesn't show in StorageLocker, even though payment succeeded (via Amazon.com). Storagelocker says to wait up to 24 hours for a purchased app to appear...which you didn't mention here.

Be that as it may, by day 3 I expected the app to show up in StorageLocker, so I could attempt another download. It has yet to show up. So I tried what you suggested in this thread (go through process and purchase again)...and still, no download. Just "payment failure".

So now what?

Only "Completed"

Only "Completed" transactions will show in your StorageLocker. If your payment fails, please contact support to share details.

It was completed.

Didn't I originally say that payment went through? The $2.99 deduction shows up on my checking account. It was processed via Amazon.com. So my transaction WAS completed.

Maybe you ought to explain what you mean by "completed". Though I can't see what else it could be.

Transaction statuses

Check the status of your transaction on your transactions tab of your profile. Only if the transaction has a status "Completed" it will appear in your StorageLocker.

Transaction statuses key:
Received: Received response from payment processor. Transaction is being validated. SlideME is requesting an 'Authorization' to eventually 'Settle' the transaction. This is not an actual 'Settled' charge on your card. Authorization is confirmed when status is 'Delivered'.
Delivered: Payment accepted, processing payment. Products were shipped.
Completed: transaction was completed, the payment related to this transaction, if any, was 'Settled' based on initial authorization.
Canceled: transaction was canceled, the Reserved (initial 'Authorization') payment related to this transaction, if any, is set to expire.

Thanks

Your explanation cleared things up. My transaction for this app is only "receieved". Have no idea why it wouldn't complete, as my amazon.com was accepted, and the 2.99 withdrawal now shows up on my checking account.

I just posted my query to the support team. Hope this gets cleared up soon. Cause it won't be a happy new year until I can torrent via my mobile device! :(